WordPress 7.1.4 Emergency Security Release: 22 Vulnerabilities Fixed — Update Now

WordPress 7.1.4 Released: Critical Security Update Requires Immediate Action

WordPress.org dropped an urgent security release on October 28, 2026 patching 22 security vulnerabilities, including a dangerous race condition in the core updater that could lead to Remote Code Execution (RCE). Site owners are strongly urged to update immediately.

What’s Fixed in WordPress 7.1.4?

This release addresses a wide range of vulnerabilities across WordPress core:

  • Remote Code Execution (RCE): A race condition during the WordPress upgrade process that could allow an attacker to execute arbitrary code during the update window, reported by Umut Bayram of Picus Security.
  • 10+ Stored Cross-Site Scripting (XSS) Issues: Multiple XSS vulnerabilities found in the Interactivity API, Customizer selective refresh, Categories block, Comments Pagination blocks, Playlist and Image blocks, and more.
  • Information Disclosure: Unpublished Customizer changesets could be discovered by unauthenticated users.
  • Stored Denial of Service: A DoS vulnerability in the Interactivity API.
  • Notes Access Control: Privileged users without post-edit access could read notes attached to posts.
  • Root Certificate Update: Bundled root certificates updated following the eMudhra revocation.

Which WordPress Versions Are Affected?

This is a broad release with backports going all the way back to WordPress 4.7:

  • WordPress 7.0 – Update to 7.0.8 (all 22 vulnerabilities)
  • WordPress 6.9 – Update to 6.9.11 (all 22 vulnerabilities)
  • WordPress 6.8 – Update to 6.8.12 (20 vulnerabilities)
  • WordPress 6.7 – Update to 6.7.11 (20 vulnerabilities)
  • WordPress 6.6 – Update to 6.6.11 (19 vulnerabilities)
  • WordPress 6.5 and earlier – Corresponding security patches available
  • WordPress 4.6 and earlier – No longer receive security updates

Key Takeaways for WordPress Site Owners

  1. Update immediately – WordPress recommends updating all sites to 7.1.4 right away.
  2. Auto-updates will handle it – Sites with automatic background updates enabled will update automatically.
  3. No exploitation reported yet – WordPress has not reported any of these vulnerabilities being actively exploited in the wild.
  4. Review user roles – Remove unneeded Contributor or Author accounts as a precaution.
  5. Plugin vulnerabilities also patched: The Ultimate Member plugin (2.13.1 and earlier) received a critical PHP Object Injection fix (CVE-2026-115968, CVSS 9.8) – update to 2.14.0 if you use it.

Why This Matters

WordPress powers approximately 39.7% of all websites on the internet (W3Techs, October 2026), making security releases like this critically important for the entire web ecosystem. The RCE vulnerability in the upgrade process is particularly noteworthy – while it requires specific timing to exploit, it underscores the importance of keeping WordPress installations current.

Hashtags: #WordPress #WebSecurity #WordPressSecurity #CyberSecurity #WebDevelopment #WordPress714 #SecurityUpdate #WPDev

Sources and Resources: